How to manage FrontPage Extentions

I had to grab this from archive.org's copy of rtr.com:





Frequently Asked Questions for the Microsoft FrontPage 2002 Server Extensions



This page contains common questions handled by our support staff, answers to questions we've received, along with some tips and tricks that we have found useful and presented here as questions. Please note that we have maintained access to the previous FAQ's (2000, 98 and 97). If you would like to submit a question.



General Information

Install Questions

Apache Questions

Security Questions

IBM eServer Questions

Client Questions

Platform Specific

Apache DSO Questions











General Information

What is the current list of supported platforms?

What are the supported webservers for the FrontPage 2002 Server Extensions?

I have other modules compiled in my existing apache daemon. What do I need to do to run the FrontPage 2002 Server Extensions?

Is there any documentation?

How do I administer the Usage Analysis in Microsoft FrontPage 2002?

How can I manage usernames and reset passwords?

When I click on "send an invitation" in the HTML based fpadmcgi.exe, I get the error message: "You cannot enable this feature because your server has not been configured to send mail" What can I do?

Hi, I have an old server running version 3 FP extensions and I want to move my web onto my new server running version 5 FP extensions. I tried manually moving the files and I ran into a bunch of functionality problems. What is the easiest way to make this transition?

I'm trying to export a Microsoft Access file as an ODBC database and use it in my Front Page web (Linux).



I'm getting the error "Using an ODBC connection, you tried to perform an operation on data in an ODBC data source. This error may occur when the ODBC data sources is on a network drive and you are not connected to the network. Make sure the network is available, and then try the operation again.

How do I set up Admin Pages for my web?

How can I set up Per User Webs from the command line?

How do I support .asp pages on my UNIX server?

When I upgraded from FPSE 2000 to FPSE 2002 my email forms no longer work. What do I need to do to fix this problem?

I'd like my error messages to be returned in . Is this possible?

My forms work fine when I send from port 80. But I receive errors when I attempt to send from port 443. How do I get my secure forms to work?

Hi,

Will people with FrontPage 2000 (and maybe even FP98) be able to work with an Apache webserver under Linux when I install the FrontPage 2002 Server Extensions!? Is it downwards compatible!?

And the other way around: when I install the FP2000 extensions, will be people with FP2002 be able to use them?

Greetings

I recently changed hosting providers for my domain. I had a FP Discussion Web in a subweb off the main web, and now it does not work correctly. When posting an article to the Discussion Web it does not seem to know that other posts have been made. (i.e.: post goes to _disc/00000001.htm instead of _disc/00000378.htm at it should have) Anyone out there seen this before, or know how to fix this??

i am using apache 1.3.22,php4.0.6,FP ver5.0 all the packages installed successfully. I can publish a FP web into the server without problem. When i try to create an email form with onSubmit="" webbot-action="--WEBBOT-SELF--", the result returns cannot run frontpage server extension in this dir. can anyone tell me what i am missing here? thanks.

Which FrontPage Server Extensions should be used with a Windows 2000 Server?

You can fill out our front page 2000 forms and they will submit to the server. However, we rarely get them...

When I use fpadmcgi.exe I keep getting this in my error log:



File does not exist: /usr/local/frontpage/version5.0/admin-exes/_vti_bin/_vti_adm/1033/IMAGESDIRbluedot.gif





How do I fix this?

I am running a web server behind a router. I am able to block access to my internal network by IP filtering. How does frontpage access the web server? Is it FTP or something else?

Is the Photo Gallery feature in FrontPage 2002 supported on the Unix platform?

After upgrading from fp2000se to fp2002se, discussion webs and email forms emailing their output in HTML formats are writing/sending the html output on one line. For large discussion webs, this is creating problems when a new post tries to add to a very very long (single) line in the tocproto.htm file.



Likewise, some clients are having email from their forms bounce due to the HTML output line being over 1024 characters long. Certain MDA's are configured to disallow long lines to prevent buffer overflow attacks.



Anyone know of a fix for this?



Many thanks



When checking my server extensions I get the following error.



The server administration programs and the server extensions on the web server are not compatible. The server is too old to use with this administration program.

Where would I look for additional information when I have problems with FrontPage Server Extensions?

I keep getting (1) Saving Form Results to E-Mail will not work unless with the "SMTPHost" or "SendMailCommand" server configuration parameters are set., how do I fix that?

How do I check that the FrontPage extensions are enabled? My FrontPage 2000 client says that the serve I am publishing to does not have FrontPage extensions installed.

I've tried everything - reinstalling, owsadm.exe -check, and I still can't open my webs with a FrontPage client. What else there to check?

FrontPage 2003 has been announced. How does it interact with the FrontPage 2003 Server Extensions?

What are the changes in SR1.2?

I am currently hosting (non-FP) pages and have someone who is requiring me to support FP2003. If I install your 2002 support on Redhat 9.0, will they be loosing the new features provided in FP2003?



Any help would be greatly appreciated...





I'm trying to setup Frontpage-EXtensions on my SuSE 9.1 and it seems I'm on a good way to make it, but I do have the following problem: When trying to access the configuration for my root-web I get the following message in the apache (2.0.49 I do think) error_log:



[Sun Jun 20 12:24:51 2004] [error] Incorrect permissions on webroot "/srv/www/htdocs/_vti_pvt" and webroot's _vti_pvt directory in FrontPageAlias().

[Sun Jun 20 12:24:51 2004] [error] Incorrect permissions on webroot "/srv/www/htdocs/_vti_pvt" and webroot's _vti_pvt directory in FrontPageAlias().

[Sun Jun 20 12:24:51 2004] [error] [client 192.168.255.254] File does not exist:

/srv/www/htdocs, referer: http://192.168.255.179:8080/





any idea?



Thanks Thomas





How do I troubleshoot a front page form that is not working



I am trying to upload my site using Front Page and am getting the following error: 404 Not Found. The requested URL /_vti_bin/_vti_aut/author.exe was not found on this server. Apache/1.3.29 Server at atlantacarservice.com Port 80, what could this mean?







Hi everyone,



I really need help from someone who has been able to make changes to the Forms that is created with Frontpage in a UNIX platform.



The problem we have is that the Form we use on our website, once they are filled out submitted by the visitor to the site and is sent to other customers who use our service. The From address email is "Username@lunarpages.com" and we don't want that, we want the From Address email to be one that we select by ourselves. Is there a code that we can include in the Frontpage Form or a instruction we can give to our host company on how to do this in their UNIX server that will allow us to change the From Address email. The hosting company told us that we need to find on how to do it and email it to them and then they will do the changes.



Thanks for the help.



Igao



Install Questions

When I run owsadm.exe -setadminport 9999 -u username -s /httpd.conf it fails. What should I do instead?

I was wondering... Do you have any sample installations using the fp_install.sh script?

I have already compiled in mod_frontpage when I built the server in the first place, and the module seems to be fine, however, now I don't know what to do to do the rest of the install process to do things like install the root web, listen on ports etc. etc. I have started the install script and its has unpacked all the files to /usr/local/frontpage However the install script quits when I tell it not to replace the currently installed httpd with the stock 1.3.19 one. How can I finish the process manually so I can get Frontpage working? Thanks for all your help in advance!

I have a new install on Linux. It appears that all went well with the install but I can't author anything. When I try to "Publish Web" with FP 2002, I get a username and password box repeatedly. I'm using the admin username and pwd that I typed in when I installed FP2002.



Specifically, I'm seeing this in the log: 192.168.0.18 - - [12/Aug/2001:14:21:31 -0700] "POST /_vti_bin/_vti_aut/author.exe HTTP/1.1" 401 264



Everything is owned by apache:apache (uid 504).



This is happening BEFORE I type in the username and password the first time and each subsequent time.



Error 401 means something is not authorized, right?



Is there any way to get more debugging information out of this? I don't have much to work with here.



Any ideas on how to fix this?



Thanks for any assistance.





During installation I received the following error: The top-level folder for web is a symbolic link and the 'FollowSymLinks' server configuration is not set. Error / installation failed. What do I need to do?

During installation I received the following error:



Upgrading FrontPage Webs

cp: cannot create regular file '/usr/sbin/httpd': Text file busy

ERROR: Unable to copy to /usr/sbin/httpd

ERROR: Unable to upgrade Apache deamon!



Now what?

I'm trying to install the extensions, but I keep getting srm.conf file does not exist (apache 1.3.19). I have checked and the file does exist. I have had the same problem with Frontpage 2000 extensions on 1.3.20. Help.



Where is fp_install.sh?





My web opens without username/password prompt.

Install to Redhat failed: "AllowOverride"



Installing the server extensions to Redhat 7.2 failed. Here are the last few

lines from the installation (I don't see an access.conf on my machine):



Installing the root web...



Server config filename: /etc/httpd/conf/httpd.conf

FrontPage Administrator's user name: joeblow



Getting User from /etc/httpd/conf/httpd.conf

Unix user name of the owner of this new web: [apache] joeblow



Getting Group from /etc/httpd/conf/httpd.conf

Unix group of this new web: [apache] joeblow

Installing root web into port 80...





Installing server / on port 80



Will chown web to joeblow as part of install.

Will chgrp web to joeblow as part of install.

Note: Local version of Apache must use the FrontPage Apache patch. Error:

FrontPage requires that the AllowOverride option be set to something other

than "None" (typically set in access.conf). "All" is the preferred

AllowOverride option for the document root.

ERROR: / installation failed.

Hit enter to continue



Now what?



How does one install a virtual web on port 443 instead of port 80?

I am getting this error message after executing the following:

./owsadm.exe -o install -u fpadm -pw test -s /etc/httpd/conf/httpd.conf \

-xuser customer -xgroup firm -p 80

Error message is:



Cannot chown content: user customer does not exist.

Cannot chown content: group firm does not exist.

I am getting this error message after executing the following:



./owsadm.exe -o install -u fpadm -pw test -s /etc/httpd/conf/httpd.conf \

-p 80



Error: The access control file "

/var/www/html/addon-modules/.htaccess" was not created by this client program and cannot be edited safely using this client program.

Running the fp_install.sh script to create the root web results in an error.



ErrorMessage:



Error: An access setup description is required when creating the root web.

ERROR: / installation failed.

Installed FP Extension 2002 on RH Linux 7.1. Run fp_install.sh without choosing root web, sub web and virtual web. But still cannot publish web site to the server. Front Page module seems to be running (checked by httpd -l).



The server you are you are publishing to does not have the Front Page Server Extensions installed and therefore does not support publishing via HTTP.





How do I resolve this issue?



How do I install FrontPage 2002 Server extensions on my apache 1.3.22 server that is already running?

I've installed the frontpage extensions and am almost positive they are in correctly. When I go to publish a web site it asks me for a login and password. Then it tells me that FrontPage extensions aren't installed on the server. How do I test it to make sure. Where is the default directories that everything is kept?

Set up a Unix user where the login begins with a number, e.g. 1coolguy

Set up a virtual host for www.1coolguy.com or something for that user.

Attempt to install frontpage extensions for that virtual host as follows:

'owsadm.exe -o install -u 1coolguy -pw password -p 80 -m

www.1coolguy.com -servconf /path/to/httpd.conf -xu 1coolguy -xg usergroup

View the error message:

Error:

Value "1coolguy" is incorrect.

Syntax error in value of "xuser" parameter.



Why is 1coolguy not valid?

I have many domains in my apache server. I would like to only have 2 use FP extensions. How can this be done?

Every time I run fp_install.sh it fails with ERROR: "/usr/local/apache/htdocs" does not exist. I checked the directory is there. Why can't fp_install.sh find it?

I would like to put a second web server on my Solaris machine and have it use a separate copy of FrontPage Extensions. It will be on a different port and in a different location. I do not want to interfere with the production server that is running. What would be involved with making this happen? Would I have to modify fp_install.sh to point the second copy of the server extensions some place other than /usr/local?

During installation using fp_install.sh I received the following error:



Are you sure that you want to do this (y/n) [N]? y

Upgrading FrontPage Webs...

cp: omitting directory `/etc/httpd/'

ERROR: Unable to copy /etc/httpd/ to /etc/httpd/.orig

ERROR: Unable to upgrade Apache daemon!

Exiting due to an error! Please fix the error and try again.



How do I fix the error?

Using the FP2002 extensions and the owsadm.exe utility I run into the oft mentioned (yet not solved situation) of "Error: Cannot open 'srm.conf': no such file or folder." when running owsadm.exe (Solaris 9, btw).



./owsadm.exe -o install -p www.somehost.com:80 -s /etc/apache/httpd.conf -u thename -pw -xu nobody -xg nobody



What is the solution?

During installation I'm getting "Error: '80' server is not a valid virtual server. How do I install?

The latest download does not support apache 2.0.48 contrary to website message.



Run fp_install to install fp on a server I just install apache 2.0.48 on.



Your site says:

"This release also includes support for Apache 1.3.29 and Apache 2.0.48."



ErrorMessage:



WARNING: The Apache you are running is newer than the one

supported by this kit.

You are running Apache 2.0.48 .

This kit supports Apache .





What is the true story?

I have a gentoo box with apache 2.0.49. I have to change some of the names on t

he script to match gentoo file names. But when installing, everything went fine

until the compile step where it game me the error bellow:



In fact there was no apache2 dir under frontpage/version5.0



What I need to fix this?



When I attempt to install the FrontPage Server Extensions for my web site with fp_install.sh or owsadm.exe I get:



installing server / on port 80



Will chown web to apache as part of install.

Will chgrp web to apache as part of install.

Error: '80' server is not a valid virtual server.

ERROR: / installation failed.

Hit enter to continue



How to I resolve this behavior?



Apache





I try to compile a custom server (Apache 1.3.22), following the instructions

on the Microsoft Web Site. But, when I run the ./configure script, it can't

find the mod_frontpage.c module! There isn't on the FrontPage 2002 Server

Extensions Distribution!!



Where I can locate this file?



I am running apache 1.3.22 and am trying to install FrontPage 2002 extension

to it. I copied fp-patch-apache_1.3.19 to fp-patch-apache_1.3.22 . I am trying to apply the patch with the following command patch -p0


File to patch: src/httpd

Hunk #1 failed at line 0.

Hunk #2 failed at line 800.

Hunk #3 failed at line 188.

Hunk #4 failed at line 576.

Hunk #5 failed at line 586.

Hunk #6 failed at line 708.

6 out of 6 hunks failed: saving rejects to src/httpd.rej

done



Help.







Hi. What is the command steps to execute the patch fp-patch-apache_1.3.22.Z

please, and what Directory should it be in? I am running Linux Mandrake 8.2 RC1

and apache version is 1.3.23.

I installed the FrontPage 2002 Server Extensions and now my Apache won't start. First it couldn't find the httpd.conf on my system and now it complains. Why?

I have downloaded the frontpage patch, and the extensions, to my computer, but how do I get them to the server?

i downloaded 2002 extensions and installed, they installed fine, but when i start apache now, i get a Syntax error on line 210 of /usr/local/apache/conf/httpd.conf : invalid command 'LoadModule', perhaps mis-spelled or defined by a module not included in the server configuration so i comment out line 210, then get the same error for line 211, so i comment out 211 and get the same error for line 212 etc... I checked the modules folder, and the modules its saying it cant load are there, any ideas ?

I've using Redhat 7.1 and it's built with apache, php, mysql, ssl from RPM. How do I do an install?

I have been trying to load frontpage 2002 into my apache 1.3.24 & when i start

apache this is written to my /var/log/httpd/error.log (see below)



[Mon May 20 15:34:51 2002] [error] (2)No such file or directory: Incorrect permissions on key directory "/usr/local/frontpage/version5.0/apache-fp" in FrontPageCheckup(). Until this problem is fixed, the FrontPage security patch is disabled and the FrontPage extensions may not work correctly



Any hints to this would be greatly appreciated



Regards





Security Questions

When I submit a form I get the following:



status=1

osstatus=0

msg=frontpage security violation

osmsg=



How do I fix this?

I have not yet installed frontpage server extensions for linux. The main reason

for changing to a Linux/Apache or windows/apache server would be to improve security. Are there any known vulnerabilities in the frontpage server extensions 200

2 for apache?

I heard there was security problem with Mod_frontpage 1.6.1. Is this true?

How does [CERT VU#944335] effect the FrontPage Server Extensions?

Client Questions

How do you get the Guestbook log to insert entries at the top of the page rather than at the bottom?

IBM eServer Questions

Do I need a special installation script for the IBM eServer zSeries FrontPage installation?

I used owsadm to setup my administration pages, but when I attempt to use them my browser wants to download fpadmcgi.exe. What can be done to fix this problem?

My installation seems to have completed correctly but when I attempt to access my site from a FrontPage client it fails. What should I check?

Platform Specific

I've installed FrontPage 2002 with no problems in the past on FreeBSD 4.4 and 4.5. I recently have tried the latest 4.7, and in the middle of the FrontPage 2002 extensions install I get the error:



Will chown web to nobody as part of install.

Will chgrp web to nobody as part of install.

/usr/libexec/ld-elf.so.1: /usr/lib/libm.so.2: Undefined symbol "__stderrp"

ERROR: / installation failed.



Please help anyone, I'm been trying differn't things for hours and will accept any advise.





Apache DSO Questions

Does anyone have fp Extensions running on RH 8.0 or 9.0? Spent past week installing/reading/tweaking/trying to make work. About ready to go back to RH 7.0. It should not be this hard to install these. I did it on a 6.1 box a while back worked like a champ. HELP!! Any would be appreciated!!

I attempted to install the administration pages on my apache 2.0.43 web and they did not appear. What is the correct command?

I've tried installing on my Redhat 8 servers and the fp_install.sh script fails with can't find apxs. Why?

I've installed the extensions on Redhat9 with Apache 2.0.40. The fp_install.sh script ran with no problem. I am still unable to access the web with a FrontPage client. I noticed that the LoadModule line for mod_frontpage was within my directives. What do I need to do?

I've installed the Apache RPM and the Apache Development RPM but fp_install.sh still fails. It is looking for instdso.sh. Where can I find this file?

When I attempt to open my web with a FrontPage client I get "POST /_vti_bin/shtml.exe/_vti_rpc hTTP/1.1" 406 521 in my log file. What needs to be done?

The installation seems to have completed, the LoadModule line is in the httpd.conf file, the Apache server has been restarted, but I still can not access the site. What else should I check?

Is there a sample install for Apache 2?

The images for my adminweb do not appear. What is wrong?

I've recently upgraded my machine from Redhat 7.3 with Apache 1.3.26 to Redhat 9 with the Apache 2 server. None of my FrontPage enabled webs are working now, where do I start?

I'm still having problems. What next?

I have FPSE installed and working from a publishing standpoint on RHES3.0 and Apache 2.0.46 (RH enterprise edition RPM's).



However even though publishing works, when end-users do FORM POSTS, they get no response on the browser and my apache error log shows:



(104)Connection reset by peer: ap_content_length_filter: apr_bucket_read() failed, referer: https://mydomain.com/ContactUs.html



I see many references to this problem via Google but no solutions that I've been able to find. Can someone please help?





I can't connect with the FrontPage client on my new Apache 2.0.48 installation. The error logs show "Wed Jan 28 11:17:58 2004] [error] [client 64.241.156.153] (13)Permission denied: unable to connect to cgi daemon after multiple tries: /usr/local/frontpage/version5.0/apache-fp/_vti_bin/fpexe". I ran the set_default_perms.sh script to adjust permissions within /usr/local/frontpage/version5.0, but I'm still getting this message. HELP!





From Support on General Questions :







General Information



What are the supported webservers for the FrontPage 2002 Server Extensions?



Effective October 1, 2004, Apache 2.0.51 is considered a supported web server for the FrontPage 2002 Server Extensions for UNIX.



Effective August 25, 2004, Apache 2.0.50 is considered a supported web server.



Effective July 15, 2004, Apache 1.3.31 is considered a supported web server.



Effective June 2004, Apache 2.0.49 is considered a supported web server.



Effective with Service Release 1.2 support for Apache 1.3.29 and Apache 2.0.48 has been added.



Effective September 2003, Apache 2.0.47 is considered a supported web server.



Effective July 2003 Apache 2.0.46 is considered a supported web server.



Effective with the release of Service Release 1, Apache 1.3.28 is considered a supported web server. You should use the patch included in the download file. Please note: Effective with Service Release 1, using mod_frontpage as a DSO is now supported. Effective with Service Release 1, Apache 2.0.43 is considered a supported web server.



Effective April 23, 2002 Apache 1.3.24 is considered a supported web server. You should use the 1.3.22 patch.



Effective February 8, 2002 Apache 1.3.23 is considered a supported web server. You should use the 1.3.22 patch.



Effective December 19, 2001 Apache 1.3.22 is considered a supported web server (the 1.3.19 patch can be applied.) Apache 1.3.22 is also considered a supported web server. The 1.3.22 patch is available here.



The only supported web server on Unix for this release is Apache 1.3.19. In order to install or upgrade to the FrontPage Server Extensions 2002 you must patch the web server with the FrontPage patch. Without the patch you will not be able to install or upgrade to the FrontPage Server Extensions 2002. If you are not running Apache or cannot migrate to it or do not want to patch the web server then you should continue to use the latest release of the FrontPage 2000 Server Extensions.



Back to FAQ



I have other modules compiled in my existing apache daemon. What do I need to do to run the FrontPage 2002 Server Extensions?



If you have other modules that you need compiled into Apache then you should manually patch your server prior to installing or upgrading. To install the patch manually, use the following steps:



bullet Untar fp50_platform_tar.Z



bullet Copy the Fp-patch-apache_1.3.x into your Apache server build directory

(usually /usr/local/Apache_1.3.x). The Fp-patch-apache_1.3.x file is found in/usr/local/frontpage/version5.0/apache-fp/fp-patch-apache_1.3.x.



bullet Using the GNU version of the patch utility, run the patch command on the

FrontPage 2002 Apache patch source file:



patch -p0


bullet Configure the server (you should include your modules and mod_frontpage.c)



./configure --add-module=mod_frontpage.c



bullet Build the Apache server: make



bullet Install the server: make Install







Back to FAQ



What is the current list of supported platforms?



Digital UNIX 5.0, 5.1

FreeBSD 5.0, 5.2

BSDi 5.0, 5.1

Linux 8 , 9 (Red Hat Software)

Red Hat Fedora Core

Red Hat Enterprise Server

Solaris-Sparc 2.8, 2.9

Solaris-Intel 2.8, 2.9

HP/UX 11, 11i

IRIX 6.3, 6.5

IBM eServer zSeries (SuSE Linux 8-)

IBM eServer pSeries (SuSE Linux 8-)

IBM eServer iSeries (SuSE Linux 8-)





Back to FAQ



Is there any documentation?



Documentation can be found here.



Back to FAQ



How do I administer the Usage Analysis in Microsoft FrontPage 2002?



Please see the usage_whitepaper.



Back to FAQ



How can I manage usernames and reset passwords?



The management of usernames can be administered by a series of command lines or by using the HTML administration pages.



For detailed information on specific commands and how to find the HTML admin pages for your server please check with the Sharepoint Documentation.



Back to FAQ



When I click on "send an invitation" in the HTML based fpadmcgi.exe, I get the error message: "You cannot enable this feature because your server has not been configured to send mail" What can I do?



You need to configure your webserver to send mail before you can use this feature. This needs to be set up by adding one of the following lines to your we80.cnf file:



SMTPHOST:xxx.xxx.xxx.xxx

or

SendMailCommand:/path/to/sendmail



Excerpt from the SharePoint document:



Mail settings



Periodically, the server sends e-mail notification or other messages to users of your site or to you, the administrator. You can specify the SMTP mail server to use for these messages. You also can type the From and Reply-to address to use for these messages, and specify which mail encoding option and character set to use in the e-mail messages. Server administrators can change these settings by using the Change Configuration Settings page (in the Virtual Server Administration pages). Web site administrators can also change the From and Reply-to addresses on the Change Web Subscription Settings page (in the Site Administration pages).





Click here for more information.



Back to FAQ



Hi, I have an old server running version 3 FP extensions and I want to move my web onto my new server running version 5 FP extensions. I tried manually moving the files and I ran into a bunch of functionality problems. What is the easiest way to make this transition?



The most efficient way to transfer your web on to your new server is to:

bullet Install the extensions on the new server

bullet If you are using straight Apache then you have to install your subwebs too

If you are using Apache with Mod FP then the subs will be created for you

bullet Open up the web in your Front Page Client on the old server

bullet Publish web to the new server



This should take care of any functionality problems.



Back to FAQ



I'm trying to export a Microsoft Access file as an ODBC database and use it in my Front Page web (Linux).



I'm getting the error "Using an ODBC connection, you tried to perform an operation on data in an ODBC data source. This error may occur when the ODBC data sources is on a network drive and you are not connected to the network. Make sure the network is available, and then try the operation again.



The first thing that you want to confirm is that your Linux machine has the windows database mounted. The database has to be available so that web users can reach it.



For information n how to mount the drive go to:

David's Linux Experience



Back to FAQ



How do I set up Admin Pages for my web?



In order to set up the Admin Pages you need to run owsadm.exe from the command line:



cd /usr/local/frontpage/version5.0/bin

./owsadm.exe -o setadminport -p -s -username -pw



Back to FAQ



How can I set up Per User Webs from the command line?



It is possible to create a per user web from the command line:



cd /usr/local/frontpage/version5.0/bin

owsadm.exe -o install -p 80 -web \~username -xu username -xg -u -pw



Please note that you may also need to add this to your config file:





AllowOverRide All





Back to FAQ



How do I support .asp pages on my UNIX server?



It is possible to use Apache with mod_perl, and create perl based asp pages which are supported by FrontPage.



Note: You can also contact Chili!Soft concerning Active Server pages. Their implementation is currently available for Solaris, AIX, HP-UX, and Linux. The Chili!Soft product has more functionality than mod_perl and does cost money.



Back to FAQ



When I upgraded from FPSE 2000 to FPSE 2002 my email forms no longer work. What do I need to do to fix this problem?



You need to edit your we80.cnf file and delete the %r from your SendMailCommand line.



SendMailCommand:/usr/sbin/sendmail





Back to FAQ



I'd like my error messages to be returned in . Is this possible?



There are additional language files available on the Microsoft site.



Back to FAQ



My forms work fine when I send from port 80. But I receive errors when I attempt to send from port 443. How do I get my secure forms to work?



You need to install the extensions against both ports (80 and 443). You can use owsadm.exe -o install -p 443 -s /path/to/httpd.conf or if your port 443 documentroot is the same as your port 80 documentroot you can simply:



cd /usr/local/frontpage

cp we80.cnf we443.cnf



Make sure ownership/permissions of we443.cnf matches we80.cnf ownership and permissions.



Back to FAQ



Hi,

Will people with FrontPage 2000 (and maybe even FP98) be able to work with an Apache webserver under Linux when I install the FrontPage 2002 Server Extensions!? Is it downwards compatible!?

And the other way around: when I install the FP2000 extensions, will be people with FP2002 be able to use them?

Greetings



The Server Extensions are backwardly compatible.



Folks with FP2002 publishing against a FP2000 enabled web will not be able to use and of the new functions. For more information check out the product guide or knowledgebase.



Back to FAQ



I recently changed hosting providers for my domain. I had a FP Discussion Web in a subweb off the main web, and now it does not work correctly. When posting an article to the Discussion Web it does not seem to know that other posts have been made. (i.e.: post goes to _disc/00000001.htm instead of _disc/00000378.htm at it should have) Anyone out there seen this before, or know how to fix this??



In order for you to have the relocated web resume postings at the correct count, you need to edit the /_vti_pvt/service.cnf and change the vti_disc_articlenumber setting to the correct number.



Sample:



/www/content/_vti_pvt/service.cnf

vti_disc_articlenumber:IX|378



Please note: you may have to have your ISP make the change if you do not have access to the _vti_pvt directory.







Back to FAQ



Which FrontPage Server Extensions should be used with a Windows 2000 Server?



Information concerning the Microsoft FrontPage Server Extensions for windows can be found on the Microsoft site.



Back to FAQ



You can fill out our front page 2000 forms and they will submit to the server. However, we rarely get them...



If your ISP has set up your web correctly, with either SendMailCommand or SMTPHost in your FrontPage config file (hostname:80.cnf), then they should be able to look in the system logs file for why you aren't always getting the results.



While waiting form them to resolve this issue you may want to change your forms to both send you mail and store the results in to file. You can then use your FrontPage client to view this file.



From your Client: Open the Form Page, and go to form properties

FormProperties

Sendto: _private/results

Email: user@hostname.com

Tools -> Options -> Advanced -> Show hidden files and folders

apply



Then you should be able to view the information stored in _private/results.



Back to FAQ



I am running apache 1.3.22 and am trying to install FrontPage 2002 extension

to it. I copied fp-patch-apache_1.3.19 to fp-patch-apache_1.3.22 . I am trying to apply the patch with the following command patch -p0


File to patch: src/httpd

Hunk #1 failed at line 0.

Hunk #2 failed at line 800.

Hunk #3 failed at line 188.

Hunk #4 failed at line 576.

Hunk #5 failed at line 586.

Hunk #6 failed at line 708.

6 out of 6 hunks failed: saving rejects to src/httpd.rej

done



Help.



There is a new patch available for Apache 1.3.22. Also you should be using GNU patch instead of the system patch as recommended in the Sharepoint documentation.



"If you have compiled an Apache Web server using a previous version of the FrontPage Apache patch source file, use the GNU version of the patch utility to remove the previous version of the FrontPage Apache patch from your Apache server:



%patch –p0 –R < previous_FrontPage_patch_file



Using the GNU version of the patch utility, run the patch command on the FrontPage Apache patch source file:



%patch –p0


"



Back to FAQ



I try to compile a custom server (Apache 1.3.22), following the instructions

on the Microsoft Web Site. But, when I run the ./configure script, it can't

find the mod_frontpage.c module! There isn't on the FrontPage 2002 Server

Extensions Distribution!!



Where I can locate this file?



The distribution includes fp-patch-apache-1.3.19, or you can pick up fp-patch-apache-1.3.22. You then need to use patch before you run configure.



Back to FAQ



When I use fpadmcgi.exe I keep getting this in my error log:



File does not exist: /usr/local/frontpage/version5.0/admin-exes/_vti_bin/_vti_adm/1033/IMAGESDIRbluedot.gif





How do I fix this?



In /usr/local/frontpage/version5.0/admin/1033/webadmin.css change



background-image: url(IMAGESDIRbluedot.gif);



to



background-image:url(IMAGESDIR/bluedot.gif);







Back to FAQ



I am running a web server behind a router. I am able to block access to my internal network by IP filtering. How does frontpage access the web server? Is it FTP or something else?



From the Microsoft SharePoint documentation:



"The FrontPage client communicates with FrontPage Server Extensions using HTTP, the same protocol Web browsers and Web servers use to communicate. FrontPage implements a remote procedure call mechanism on top of the HTTP POST request, so that the FrontPage client can request documents, update the Tasks list, add new authors, and so on."



Back to FAQ



Hi. What is the command steps to execute the patch fp-patch-apache_1.3.22.Z

please, and what Directory should it be in? I am running Linux Mandrake 8.2 RC1 and apache version is 1.3.23.



You need to be in your Apache src directory (get the source code from www.apache.org). You should then uncompress the .Z file and run the commands as documented in SharePoint.



Back to FAQ



I have downloaded the frontpage patch, and the extensions, to my computer, but how do I get them to the server?



You can now ftp them from your PC to your server. Please note that you must have ROOT access on your server to install the FrontPage Server Extensions. If you are using a Web Host for your site, it is unlikely that you will be able to install the extensions for your site. You will need to contact your web host and ask them about installing the extensions on the server and FrontPage enabling your web.



Back to FAQ



Is the Photo Gallery feature in FrontPage 2002 supported on the Unix platform?



Yes, Photo Gallery is support on the FrontPage 2002 Server Extensions for Unix.



Back to FAQ



After upgrading from fp2000se to fp2002se, discussion webs and email forms emailing their output in HTML formats are writing/sending the html output on one line. For large discussion webs, this is creating problems when a new post tries to add to a very very long (single) line in the tocproto.htm file.



Likewise, some clients are having email from their forms bounce due to the HTML output line being over 1024 characters long. Certain MDA's are configured to disallow long lines to prevent buffer overflow attacks.



Anyone know of a fix for this?



Many thanks



In the html try changing



s-article-format="HTML/PRE"



to



s-article-format="HTML/BR"



Back to FAQ



When checking my server extensions I get the following error.



The server administration programs and the server extensions on the web server are not compatible. The server is too old to use with this administration program.



Check the frontpage configuration file for your web (/usr/local/frontpage/we80.cnf) and confirm that your extenderversion parameter is correct for your web and extensions.





Back to FAQ



Where would I look for additional information when I have problems with FrontPage Server Extensions?



If you are having problems with the FrontPage Server Extensions you can look at your Apache access and error logs, your system messages file (as defined in /etc/syslog.conf), and on the client side in wecerr.txt.



The Sharepoint Documentation, this FAQ, the FP2002 discussion Group, and the microsoft.public.frontpage.extensions.unix discussion group also provide information.



Back to FAQ



I keep getting (1) Saving Form Results to E-Mail will not work unless with the "SMTPHost" or "SendMailCommand" server configuration parameters are set., how do I fix that?



If you have access to the web server you can edit the we80.cnf or virtualhost:80.cnf file found in /usr/local/frontpage and add the SMTPhost or SendMailCommand appropriate for your system. For Example:



SendMailCommand:/usr/sbin/sendmail



If you do not have access to the web server, you need to ask your ISP to make the addition for you.



Back to FAQ



How do I check that the FrontPage extensions are enabled? My FrontPage 2000 client says that the serve I am publishing to does not have FrontPage extensions installed.



There are a few things to try to confirm if the FrontPage Server Extensions are installed on your web.

bullet Try browsing: http://yourweb.com/postinfo.html

bullet Try opening the web with your FrontPage Client

bullet If you have problems opening the web check the wecerr.txt file for additional information. You might see:

bullet Server error: You must use a secure connection (SSL) to

author against this server.

bullet HTTP 500 Error from proxy

bullet Server error: The server extensions were unable to

access the file "httpd.conf.3185". Please check the file

permissions.







Back to FAQ



I've tried everything - reinstalling, owsadm.exe -check, and I still can't open my webs with a FrontPage client. What else there to check?



There are a number of areas that can be checked:

bullet Apache Access and Error Logs

bullet System Messages Files

bullet SUEXEC logs

bullet Are you using symlinks? and does FrontPage know

bullet edit frontpage.cnf and add followsymlinks:1

bullet Are your partitions mounted SUID ?

bullet Do you have the AllowOverRide All set for the documentroot

bullet Did you check your .htaccess files?



Back to FAQ



I'm trying to setup Frontpage-EXtensions on my SuSE 9.1 and it seems I'm on a good way to make it, but I do have the following problem: When trying to access the configuration for my root-web I get the following message in the apache (2.0.49 I do think) error_log:



[Sun Jun 20 12:24:51 2004] [error] Incorrect permissions on webroot "/srv/www/htdocs/_vti_pvt" and webroot's _vti_pvt directory in FrontPageAlias().

[Sun Jun 20 12:24:51 2004] [error] Incorrect permissions on webroot "/srv/www/htdocs/_vti_pvt" and webroot's _vti_pvt directory in FrontPageAlias().

[Sun Jun 20 12:24:51 2004] [error] [client 192.168.255.254] File does not exist:

/srv/www/htdocs, referer: http://192.168.255.179:8080/





any idea?



Thanks Thomas



Similar to the 2000 extensions this error can be found in the mod_frontpage code:



{

/

The webroot and webroot/_vti_pvt don't match. User recovery: fix

the owners and groups of both directories to match, and have both a

uid and gid in the allowable range.

/

LogFrontPageError(r->server, "Incorrect permissions on webroot \"%-.0124s\" and webroot's _vti_pvt directory", szBuf, "FrontPageAlias()", FALSE, 0);

return DECLINED;

}



if ((!strcmp(r->filename,GLOBALADMINDIR)) ? vti_pvt.st_uid > 0

: (vti_pvt.st_uid < LOWEST_VALID_UID || vti_pvt.st_gid < LOWEST_VALID_GID))

{

/


User recovery: fix the owners and groups of both directories to

match, and have both a uid and gid in the allowable range.

/

LogFrontPageError(r->server, "Incorrect permissions on webroot \"%-.0124s\" and webroot's _vti_pvt directory", szBuf, "FrontPageAlias()", FALSE, 0);

return DECLINED;

}





You need to check that your UID and GID are within the allowable ranges and that the permissions on the directories match.







Back to FAQ



How do I troubleshoot a front page form that is not working ?





To troubleshoot FrontPage problems:

bullet Review the Apache error log

bullet Review the Apache access log

bullet Review the system messages file

bullet Check you system mail messages file

bullet Check your SUEXEC logs



Back to FAQ



I am trying to upload my site using Front Page and am getting the following error: 404 Not Found. The requested URL /_vti_bin/_vti_aut/author.exe was not found on this server. Apache/1.3.29 Server at atlantacarservice.com Port 80, what could this mean?



It appears that atlantacarservice.com and www.altantacarservice.com have not been FrontPage enabled. You need to have your ISP enable (extend) your site with the Extensions.



owsadm.exe -o install -t apache-fp -xu -xg \

-s
-u -pw -p 80 \

-m atlantacarservice.com



Back to FAQ



Hi everyone,



I really need help from someone who has been able to make changes to the Forms that is created with Frontpage in a UNIX platform.



The problem we have is that the Form we use on our website, once they are filled out submitted by the visitor to the site and is sent to other customers who use our service. The From address email is "Username@lunarpages.com" and we don't want that, we want the From Address email to be one that we select by ourselves. Is there a code that we can include in the Frontpage Form or a instruction we can give to our host company on how to do this in their UNIX server that will allow us to change the From Address email. The hosting company told us that we need to find on how to do it and email it to them and then they will do the changes.



Thanks for the help.



Igao



Your ISP can edit your /usr/local/frontpage/WEBNAME:80.cnf file and add the mailsender configuration variable.





From FrontPage Extension for Unix Install Questions:



Install Questions



When I run owsadm.exe -setadminport 9999 -u name -s /httpd.conf it fails. What should I do instead?



You need to use -username name instead of the -u name.



Back to FAQ



I installed the FrontPage 2002 Server Extensions and now my Apache won't start. First it couldn't find the httpd.conf on my system and now it complains. Why?



As noted during the installation:



"The Apache daemon is going to be replaced with a stock Apache containing the FrontPage patch and may result in the loss of any custom modules that have been compiled into the daemon that is currently in use."



Therefore you need to determine which modules were included in your original Apache daemon and recompile with those modules and mod_frontpage.c. Please check the documentation for more information.



Back to FAQ



I was wondering... Do you have any sample installations using the fp_install.sh script?



Yes we do, although these answers may not be exactly what you'll want to use for you web they should still give you a good idea of "normal" answers.



Sample Install Using fp_install.sh



Back to FAQ



I have already compiled in mod_frontpage when I built the server in the first place, and the module seems to be fine, however, now I don't know what to do to do the rest of the install process to do things like install the root web, listen on ports etc. etc. I have started the install script and its has unpacked all the files to /usr/local/frontpage However the install script quits when I tell it not to replace the currently installed httpd with the stock 1.3.19 one. How can I finish the process manually so I can get Frontpage working? Thanks for all your help in advance!



Make a copy of the current httpd to a different location. When the install script ask for the location of the httpd, point it to the one you just copied.



Back to FAQ



I have a new install on Linux. It appears that all went well with the install but I can't author anything. When I try to "Publish Web" with FP 2002, I get a username and password box repeatedly. I'm using the admin username and pwd that I typed in when I installed FP2002.



Specifically, I'm seeing this in the log: 192.168.0.18 - - [12/Aug/2001:14:21:31 -0700] "POST /_vti_bin/_vti_aut/author.exe HTTP/1.1" 401 264



Everything is owned by apache:apache (uid 504).



This is happening BEFORE I type in the username and password the first time and each subsequent time.



Error 401 means something is not authorized, right?



Is there any way to get more debugging information out of this? I don't have much to work with here.



Any ideas on how to fix this?



Thanks for any assistance.



You need to make sure that the AllowOverRide All directive for each documentroot - Virtual Hosts and peruser webs.







Back to FAQ



i downloaded 2002 extensions and installed, they installed fine, but when i start apache now, i get a Syntax error on line 210 of /usr/local/apache/conf/httpd.conf : invalid command 'LoadModule', perhaps mis-spelled or defined by a module not included in the server configuration so i comment out line 210, then get the same error for line 211, so i comment out 211 and get the same error for line 212 etc... I checked the modules folder, and the modules its saying it cant load are there, any ideas ?



As noted during the installation:



"The Apache daemon is going to be replaced with a stock Apache containing the FrontPage patch and may result in the loss of any custom modules that have been compiled into the daemon that is currently in use."



Therefore you need to determine which modules were included in your original Apache daemon and recompile with those modules and mod_frontpage.c. Please check the documentation for more information.



Back to FAQ



During installation I received the following error: The top-level folder for web is a symbolic link and the 'FollowSymLinks' server configuration is not set. Error / installation failed. What do I need to do?



Please confirm that you have the symlinks directive correct in your httpd.conf. If this is correct then you must also tell FrontPage that you are using symlinks. You can do this by editing your /usr/local/frontpage/version5.0/frontpage.cnf file and adding.



followsymlinks:1



From the documentation: "A non-zero value for this parameter allows the FrontPage Explorer and the FrontPage Server Administrator (owsadm) to operate on folders that are linked to symbolically from a web content area. For example, this would permit the FrontPage Explorer to display the contents of a symbolically linked directory. Default value = 0."



Back to FAQ



During installation I received the following error:



Upgrading FrontPage Webs

cp: cannot create regular file '/usr/sbin/httpd': Text file busy

ERROR: Unable to copy to /usr/sbin/httpd

ERROR: Unable to upgrade Apache deamon!



Now what?



The installation is attempting to copy the Apache deamon that is shipped with the extensions to your /usr/sbin location. Because your Apache deamon is currently running the copy failed. You can stop your Apache deamon and rerun fp_install.sh then restart the new Apache deamon, or you can manually replace the httpd.



Stop your Apache



mv /usr/sbin/httpd /usr/sbin/httpd.orig

cp /usr/local/frontpage/version5.0/apache-fp/httpd /usr/sbin/httpd



then restart your Apache



Back to FAQ



I'm trying to install the extensions, but I keep getting srm.conf file does not exist (apache 1.3.19). I have checked and the file does exist. I have had the same problem with Frontpage 2000 extensions on 1.3.20. Help.



You may need to set your ResourceConfig and AccessConfig to point to the location of your srm.conf and access.conf in your httpd.conf. Or you can use:



ResourceConfig /dev/null

AccessConfig /dev/null



Back to FAQ



Where is fp_install.sh?



fp_install.sh is included in the tar file or you can download it here. You will have to gunzip the file and set it executable before you can use.



Back to FAQ



My web opens without username/password prompt.



Apache:



Setting this parameter to All in your apache configuration file will alleviate this problem.



AllowOverride ALL



Please note that you will need to do this for each unique documentroot

on your system (i.e. VirtualWebs).



Back to FAQ



Install to Redhat failed: "AllowOverride"



Installing the server extensions to Redhat 7.2 failed. Here are the last few

lines from the installation (I don't see an access.conf on my machine):



Installing the root web...



Server config filename: /etc/httpd/conf/httpd.conf

FrontPage Administrator's user name: joeblow



Getting User from /etc/httpd/conf/httpd.conf

Unix user name of the owner of this new web: [apache] joeblow



Getting Group from /etc/httpd/conf/httpd.conf

Unix group of this new web: [apache] joeblow

Installing root web into port 80...





Installing server / on port 80



Will chown web to joeblow as part of install.

Will chgrp web to joeblow as part of install.

Note: Local version of Apache must use the FrontPage Apache patch. Error:

FrontPage requires that the AllowOverride option be set to something other

than "None" (typically set in access.conf). "All" is the preferred

AllowOverride option for the document root.

ERROR: / installation failed.

Hit enter to continue



Now what?



Apache has combined the older model of 3 configuration files (httpd.conf, access.conf, and srm.conf) into the single httpd.conf.



You need to set the AllowOverRide parameter for your documentroot.



For example: if DocumentRoot is defined as /www/home you would need





AllowOverRide All









Back to FAQ



I've using Redhat 7.1 and it's built with apache, php, mysql, ssl from RPM. How do I do an install?



You can use either fp_install.sh or owsadm.exe to install the FrontPage Server Extensions for Unix. You then need to recompile your Apache deamon with the mods included in the RPM and mod_frontpage. The SharePoint documentation has additional information.



Back to FAQ



How does one install a virtual web on port 443 instead of port 80?



You should the owsadm.exe command line to install for port 443:



cd /usr/local/frontpage/version5.0/bin

./owsadm.exe -o install -p 443 -s -xu UNIXUSER -xg UNIXGROUP -u USERNAME -pw PASSWORD -m virtualweb



Back to FAQ



I am getting this error message after executing the following:

./owsadm.exe -o install -u fpadm -pw test -s /etc/httpd/conf/httpd.conf \

-xuser customer -xgroup firm -p 80

Error message is:



Cannot chown content: user customer does not exist.

Cannot chown content: group firm does not exist.



The -xuser and -xgroup must be defined on your system. FrontPage refers to the system password and group files to verify that the xuser is a valid system user and that xgroup is a valid system group.



Back to FAQ



I am getting this error message after executing the following:



./owsadm.exe -o install -u fpadm -pw test -s /etc/httpd/conf/httpd.conf \

-p 80



Error: The access control file "

/var/www/html/addon-modules/.htaccess" was not created by this client program and cannot be edited safely using this client program.



You should:



cd /var/www/html/addon-modules/

mv .htaccess .htaccess.org



Then try your installation.



Back to FAQ



Running the fp_install.sh script to create the root web results in an error.



ErrorMessage:



Error: An access setup description is required when creating the root web.

ERROR: / installation failed.



Confirm that any .htaccess files in your documentroot have been moved to .htaccess.orig. Then try your installation.



Back to FAQ



Installed FP Extension 2002 on RH Linux 7.1. Run fp_install.sh without choosing root web, sub web and virtual web. But still cannot publish web site to the server. Front Page module seems to be running (checked by httpd -l).



The server you are you are publishing to does not have the Front Page Server Extensions installed and therefore does not support publishing via HTTP.





How do I resolve this issue?



You need to enable your web with the FPSE's, not just place them on your system. Run fp_install.sh again, and when the scripts prompts you; "Do you want to install a root web (y/n)" answer yes.



Back to FAQ



How do I install FrontPage 2002 Server extensions on my apache 1.3.22 server that is already running?



If you are already running Apache 1.3.22 you need to confirm that your daemon has the mod_frontpage patch applied. You can do this by running httpd -l and grepping the results for mod_frontpage. If your daemon is patched, then run fp_install.sh and answer the questions appropriately for your system. During installation your httpd was moved to httpd.orig and the daemon which shipped with the FPSEs was copied to httpd. You can simply replace httpd with httpd.orig.



cd httpd.orig

mv httpd.orig httpd



Then restart your daemon.



If your 1.3.22 Apache does not have mod_frontpage you will need to download the Apache source code, download the frontpage patch and recompile.



Back to FAQ



I've installed the frontpage extensions and am almost positive they are in correctly. When I go to publish a web site it asks me for a login and password. Then it tells me that FrontPage extensions aren't installed on the server. How do I test it to make sure. Where is the default directories that everything is kept?



The Sharepoint documentation contains a list of which files and directories are installed when you enable a web with the FrontPage Server Extensions.



Back to FAQ



I have been trying to load frontpage 2002 into my apache 1.3.24 & when i start

apache this is written to my /var/log/httpd/error.log (see below)



[Mon May 20 15:34:51 2002] [error] (2)No such file or directory: Incorrect permissions on key directory "/usr/local/frontpage/version5.0/apache-fp" in FrontPageCheckup(). Until this problem is fixed, the FrontPage security patch is disabled and the FrontPage extensions may not work correctly



Any hints to this would be greatly appreciated



Regards



If you look at the source code for the mod_frontpage patch your solution is there:



+ {

+ /


+ User recovery: set directory to be owned by root with permissions

+
rwx--x--x. Note you need the execute bit for group and other so

+ that non-root programs can run apache-fp/_vti_bin/fpexe (even though

+
non-root cannot list the directory).

+ */

+ LogFrontPageError(s, "Incorrect permissions on key directory \"%-.1024s\"",

+ FPKEYDIR, "FrontPageCheckup()", TRUE);

+ return (FALSE);

+ }

+





Back to FAQ



Set up a Unix user where the login begins with a number, e.g. 1coolguy

Set up a virtual host for www.1coolguy.com or something for that user.

Attempt to install frontpage extensions for that virtual host as follows:

'owsadm.exe -o install -u 1coolguy -pw password -p 80 -m

www.1coolguy.com -servconf /path/to/httpd.conf -xu 1coolguy -xg usergroup

View the error message:

Error:

Value "1coolguy" is incorrect.

Syntax error in value of "xuser" parameter.



Why is 1coolguy not valid?



While 1coolguy may be a valid UNIX user on your system on many systems (the extensions must support 8 different versions of UNIX), this is not a valid UNIX user on all platforms. From the Solaris documentation:



"User names, also called login names, let users access their own systems and remote systems that have the appropriate access privileges. You must choose a user name for each user account you create. User names must:

bullet Be unique within your organization, which might span multiple domains

bullet Contain from two to eight letters and numerals (the first character must be a letter and at least one character must be a lowercase letter)

bullet Not contain an underscore or space "







Back to FAQ



I have many domains in my apache server. I would like to only have 2 use FP extensions. How can this be done?



You need to enable the extensions on only those domains which require them. You can use fp_install.sh and select only those domains (VirtualWebs) that you want to have the extensions or you can use owsadm.exe and specify which domains. Check the SharePoint Documentation.



owsadm.exe -o install -s -u -pw -xu -xg -m



Back to FAQ



Every time I run fp_install.sh it fails with ERROR: "/usr/local/apache/htdocs" does not exist. I checked the directory is there. Why can't fp_install.sh find it?



fp_install.sh has a problem with the quotes "'s in your httpd.conf file. If you removed them from the DocumentRoot directive it should work.



DocumentRoot "/usr/local/apache/htdocs"

to

DocumentRoot /usr/local/apache/htdocs



Back to FAQ



I would like to put a second web server on my Solaris machine and have it use a separate copy of FrontPage Extensions. It will be on a different port and in a different location. I do not want to interfere with the production server that is running. What would be involved with making this happen? Would I have to modify fp_install.sh to point the second copy of the server extensions some place other than /usr/local?



You don't need to have 2 separate copies of the FrontPage Server Extensions. You can simple place your test web on a different port and have it's document root in a different place than your production server. The FrontPage Server Extensions require placement in /usr/local/frontpage or a link to that directory.



Back to FAQ



During installation using fp_install.sh I received the following error:



Are you sure that you want to do this (y/n) [N]? y

Upgrading FrontPage Webs...

cp: omitting directory `/etc/httpd/'

ERROR: Unable to copy /etc/httpd/ to /etc/httpd/.orig

ERROR: Unable to upgrade Apache daemon!

Exiting due to an error! Please fix the error and try again.



How do I fix the error?



You need to give the full path to the apache deamon, not just which directory it is in. Instead of /etc/httpd you probably need to use /usr/httpd/sbin/httpd. You can use the system find to locate your Apache daemon.







Back to FAQ



Using the FP2002 extensions and the owsadm.exe utility I run into the oft mentioned (yet not solved situation) of "Error: Cannot open 'srm.conf': no such file or folder." when running owsadm.exe (Solaris 9, btw).



./owsadm.exe -o install -p www.somehost.com:80 -s /etc/apache/httpd.conf -u thename -pw -xu nobody -xg nobody



What is the solution?



The solution for Apache 2 webs is:



When installing the FrontPage Server Extensions for an Apache 2.0 web the commands are:



Root web:



owsadm.exe -o install -t apache-2.0 -p 80 -s /etc/apache/httpd.conf -u -pw

-ux nobody -xg nogroup



Virtual Web:



owsadm.exe -o install -t apache-2.0 -p 80 -s /etc/apache/httpd.conf -u -pw

-xu nobody -xg nobody -m www.somehost.name



The solution for Apache 1.3 webs is to add



ResourceConfig /dev/null

AccessConfig /dev/null



to your httpd.conf file prior to running owsadm.exe. (Please note that the -t variable for Apache 1.3 webs is apache-fp.)



Back to FAQ



During installation I'm getting "Error: '80' server is not a valid virtual server. How do I install?



In your httpd.conf file change



ServerName www.servername.com



to



ServerName www.servername.com:80







An additional option from the user community: When asked by fp_install.sh for the port number enter :80.



(Thank you)







Back to FAQ



The latest download does not support apache 2.0.48 contrary to website message.



Run fp_install to install fp on a server I just install apache 2.0.48 on.



Your site says:

"This release also includes support for Apache 1.3.29 and Apache 2.0.48."



ErrorMessage:



WARNING: The Apache you are running is newer than the one

supported by this kit.

You are running Apache 2.0.48 .

This kit supports Apache .





What is the true story?



Apache 2.0.48 is supported with the latest release of the extensions.



This is a benign message and the FPSEs do support Apache 2.0.48. If you ignore the message and continue the installation mod_frontpage.so will be created for your Apache.





Back to FAQ



I have a gentoo box with apache

Trackbacks

    No Trackbacks

Comments

Display comments as (Linear | Threaded)

    No comments


Add Comment


Enclosing asterisks marks text as bold (*word*), underscore are made via _word_.
Standard emoticons like :-) and ;-) are converted to images.

To prevent automated Bots from commentspamming, please enter the string you see in the image below in the appropriate input box. Your comment will only be submitted if the strings match. Please ensure that your browser supports and accepts cookies, or your comment cannot be verified correctly.
CAPTCHA 1CAPTCHA 2CAPTCHA 3CAPTCHA 4CAPTCHA 5


Enclosing asterisks marks text as bold (*word*), underscore are made via _word_.
Standard emoticons like :-) and ;-) are converted to images.

To prevent automated Bots from commentspamming, please enter the string you see in the image below in the appropriate input box. Your comment will only be submitted if the strings match. Please ensure that your browser supports and accepts cookies, or your comment cannot be verified correctly.
CAPTCHA 1CAPTCHA 2CAPTCHA 3CAPTCHA 4CAPTCHA 5